Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Computer Information (http://www.velocityreviews.com/forums/f41-computer-information.html)
-   -   USB Printer Disappears on Cold Boot (http://www.velocityreviews.com/forums/t538265-usb-printer-disappears-on-cold-boot.html)

John 09-18-2007 07:18 PM

USB Printer Disappears on Cold Boot
 
I have an odd problem and can't seem to resolve it. Here are the
specs:

*Dell Dimension 9200, 2.4 GHz Core 2 Duo, 1 GB RAM (Received with
Vista pre-installed, formatted and installed XP Pro; installed all
correct/most recent Dell drivers, etc.), USB only (as with all new
Dimension 9200s - no parallel, no PS/2, no serial)
*HP CP3505n Color LaserJet Printer, connected via USB (installed
drivers, etc. - everything works great...eventually)

Here's the scenario:

Computer is present in a public access computer lab, shut off each
night (in theory). Printer stays on 24x7 (not ideal, just the way it
goes). Whenever a cold boot of the PC occurs, the USB printer is not
present in Device Manager; obviously users can't print (immediately
receive an error). After reseating the USB cable, printer immediately
initializes and the queued print job (the one that just failed) prints
flawlessly. Equally, if the PC is booted, USB cable remains
untouched, but printer is power cycled, same result occurs (printer
appears in Device Manager, prints queued jobs, life is good). However,
as this is in a public computer lab, having to reseat the USB cable or
power cycle the printer is not an acceptable solution. If the PC is
left on or bounced, problem does not exist - PC was bounced
repeatedly, printer stays in tact (after initial reseating of USB
cable after cold boot). Have tried installing USB expansion card and
experienced the anticipated result: didn't make any difference
(figured as much, but had to give it a shot). Really don't want to
have to install a parallel port expansion card.

Any insight as to what may be causing this is welcome and would be
appreciated.

Thanks in advance.


John 09-18-2007 07:39 PM

Re: USB Printer Disappears on Cold Boot
 
Additional note: not all USB is stopping, as I have a USB keyboard/
mouse that work just fine. It's merely the printer that ceases to
exist.


Brian 09-23-2007 01:01 PM

Re: USB Printer Disappears on Cold Boot
 
Do you have that printer set as the default printer in XP?

Do you have the most current drivers for that printer installed?

Has the BIOS and firmware for both the computer and printer been updated to
the latest?

These are the most common reasons for the problem you are experiencing. Here
is a link to MS Knowledgebase to assist:
http://support.microsoft.com/kb/310575



John 09-24-2007 09:11 PM

Re: USB Printer Disappears on Cold Boot
 
Hey Brian,

Yes, I have it set as the default printer; it's the only printer
installed on the machine (and yes, I've verified this).

Yes, the BIOS has been updated on the computer to no avail. I
contacted HP about a firmware upgrade and was informed that the
printer is "too new" to have a firmware upgrade yet, but it is
supposedly being worked on and should be released "very soon."

Further searching led me to here:
http://forums1.itrc.hp.com/service/f...06888+28353475.
Based on what I've experienced and what I read here, it sounds like
the firmware upgrade should solve the problem, if/when it gets
released. Until then, I've installed a parallel port expansion card
and will have to run off of that.

Thanks for your help and suggestions.


On Sep 23, 8:01 am, "Brian" <bds1compu...@sio.midco.net> wrote:
> Do you have that printer set as the default printer in XP?
>
> Do you have the most current drivers for that printer installed?
>
> Has the BIOS and firmware for both the computer and printer been updated to
> the latest?
>
> These are the most common reasons for the problem you are experiencing. Here
> is a link to MS Knowledgebase to assist:http://support.microsoft.com/kb/310575




Paul 09-25-2007 12:36 AM

Re: USB Printer Disappears on Cold Boot
 
John wrote:
> Hey Brian,
>
> Yes, I have it set as the default printer; it's the only printer
> installed on the machine (and yes, I've verified this).
>
> Yes, the BIOS has been updated on the computer to no avail. I
> contacted HP about a firmware upgrade and was informed that the
> printer is "too new" to have a firmware upgrade yet, but it is
> supposedly being worked on and should be released "very soon."
>
> Further searching led me to here:
> http://forums1.itrc.hp.com/service/f...06888+28353475.
> Based on what I've experienced and what I read here, it sounds like
> the firmware upgrade should solve the problem, if/when it gets
> released. Until then, I've installed a parallel port expansion card
> and will have to run off of that.
>
> Thanks for your help and suggestions.
>


I can see a couple other possibilities. If the computer is being put in
"soft off" every night, rather than switching off at the back, then you'd
still have +5VSB running. Some motherboards have a jumper, to set the
USB port to either run from the +5V supply or from +5VSB. Typically, the
purpose of +5VSB is to power USB devices that might be used to wake the
computer.

Maybe if the printer port was powered from +5VSB, while the computer was
off, the initialization sequence might work a bit better.

As an alternative to unseating the cable, there are USB switch boxes, where
you can leave the cables connected. Pressing the button on the USB switch
box, would create a similar event, to plugging in the cable. (Note that
some USB switch boxes have a really crappy button on top, and before too long,
the switch falls apart from usage. Check the customer reviews for any
evidence of that kind of thing, before buying.)

http://www.newegg.com/Product/Produc...82E16817111708

Paul

>
> On Sep 23, 8:01 am, "Brian" <bds1compu...@sio.midco.net> wrote:
>> Do you have that printer set as the default printer in XP?
>>
>> Do you have the most current drivers for that printer installed?
>>
>> Has the BIOS and firmware for both the computer and printer been updated to
>> the latest?
>>
>> These are the most common reasons for the problem you are experiencing. Here
>> is a link to MS Knowledgebase to assist:http://support.microsoft.com/kb/310575

>
>



All times are GMT. The time now is 01:11 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.