Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   release mode Compile error BC2014 (http://www.velocityreviews.com/forums/t521768-release-mode-compile-error-bc2014.html)

news.microsoft.com 07-13-2007 06:09 PM

release mode Compile error BC2014
 
I have an asp.net 2.0 project that when I change the build configuration to
release I get the following error:

Command line error BC2014: the value 'None' is invalid for option
'debug'.

If I go into the projects Advanced Compile Options and change the Generate
Debug Info dropdown from None to PDB-Only the error goes away. Can anyone
explain why I have to do this and what can I do to get the one option to
work on a asp.net project? It is causing problems because the common
project is shared with a VB project that gets an error on release mode
compile if it is set to pdb-only.

Thanks for your help.



Juan T. Llibre 07-13-2007 06:20 PM

Re: release mode Compile error BC2014
 
Just add this entry to the web.config file :


<compilation debug="true" />



Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"news.microsoft.com" <twsilentdeath@hotmail.com> wrote in message news:e4pTxjXxHHA.736@TK2MSFTNGP06.phx.gbl...
>I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:
>
> Command line error BC2014: the value 'None' is invalid for option 'debug'.
>
> If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
> release mode compile if it is set to pdb-only.
>
> Thanks for your help.
>




nahid 07-13-2007 06:27 PM

Re: release mode Compile error BC2014
 
On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
> Just add this entry to the web.config file :
>
> <compilation debug="true" />
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en español :http://asp.net.do/foros/
> ======================================
>
>
>
> "news.microsoft.com" <twsilentde...@hotmail.com> wrote in messagenews:e4pTxjXxHHA.736@TK2MSFTNGP06.phx.gbl.. .
> >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
> > release mode compile if it is set to pdb-only.

>
> > Thanks for your help.- Hide quoted text -

>
> - Show quoted text -


hai,
he try build in release mode better set
<compilation debug="false" />

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd


Juan T. Llibre 07-13-2007 06:53 PM

Re: release mode Compile error BC2014
 
re:
!> he try build in release mode better set
!> <compilation debug="false" />

No. He said that when :

!> I change the build configuration to release

....the error occurs, therefore setting it to debug="true" should fix it.

Your suggestion, debug="false", is the same as setting the application
to release mode, so he would likely continue to get the same error as
whenhe manually sets it to "release" mode.





Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"nahid" <nahidupa@gmail.com> wrote in message news:1184351227.978857.283030@k79g2000hse.googlegr oups.com...
On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
> Just add this entry to the web.config file :
>
> <compilation debug="true" />
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en español :http://asp.net.do/foros/
> ======================================
>
>
>
> "news.microsoft.com" <twsilentde...@hotmail.com> wrote in messagenews:e4pTxjXxHHA.736@TK2MSFTNGP06.phx.gbl.. .
> >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
> > on
> > release mode compile if it is set to pdb-only.

>
> > Thanks for your help.- Hide quoted text -

>
> - Show quoted text -


hai,
he try build in release mode better set
<compilation debug="false" />

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd



nahid 07-13-2007 07:18 PM

Re: release mode Compile error BC2014
 
On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
> re:
> !> he try build in release mode better set
> !> <compilation debug="false" />
>
> No. He said that when :
>
> !> I change the build configuration to release
>
> ...the error occurs, therefore setting it to debug="true" should fix it.
>
> Your suggestion, debug="false", is the same as setting the application
> to release mode, so he would likely continue to get the same error as
> whenhe manually sets it to "release" mode.
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en español :http://asp.net.do/foros/
> ======================================"nahid" <nahid...@gmail.com> wrote in messagenews:1184351227.978857.283030@k79g2000hse.g ooglegroups.com...
>
> On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
> wrote:
>
>
>
>
>
> > Just add this entry to the web.config file :

>
> > <compilation debug="true" />

>
> > Juan T. Llibre, asp.net MVP
> > asp.net faq :http://asp.net.do/faq/
> > foros de asp.net, en español :http://asp.net.do/foros/
> > ======================================

>
> > "news.microsoft.com" <twsilentde...@hotmail.com> wrote in messagenews:e4pTxjXxHHA.736@TK2MSFTNGP06.phx.gbl.. .
> > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
> > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
> > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
> > > on
> > > release mode compile if it is set to pdb-only.

>
> > > Thanks for your help.- Hide quoted text -

>
> > - Show quoted text -

>
> hai,
> he try build in release mode better set
> <compilation debug="false" />
>
> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted text -
>
> - Show quoted text -


well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /> because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd


Juan T. Llibre 07-13-2007 07:48 PM

Re: release mode Compile error BC2014
 
re:
!> well so what is basically main problem, say i'm not prefer set
!> <compilation debug="true" /> because of loss some performance

True enough, but to resolve the *current* problem ( that the app won't run ),
the solution is get get the app working *first* and then *later* we worry about performance.



Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"nahid" <nahidupa@gmail.com> wrote in message news:1184354298.750859.148760@q75g2000hsh.googlegr oups.com...
On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
> re:
> !> he try build in release mode better set
> !> <compilation debug="false" />
>
> No. He said that when :
>
> !> I change the build configuration to release
>
> ...the error occurs, therefore setting it to debug="true" should fix it.
>
> Your suggestion, debug="false", is the same as setting the application
> to release mode, so he would likely continue to get the same error as
> whenhe manually sets it to "release" mode.
>
> Juan T. Llibre, asp.net MVP
> asp.net faq :http://asp.net.do/faq/
> foros de asp.net, en español :http://asp.net.do/foros/
> ======================================"nahid" <nahid...@gmail.com> wrote in
> messagenews:1184351227.978857.283030@k79g2000hse.g ooglegroups.com...
>
> On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
> wrote:
>
>
>
>
>
> > Just add this entry to the web.config file :

>
> > <compilation debug="true" />

>
> > Juan T. Llibre, asp.net MVP
> > asp.net faq :http://asp.net.do/faq/
> > foros de asp.net, en español :http://asp.net.do/foros/
> > ======================================

>
> > "news.microsoft.com" <twsilentde...@hotmail.com> wrote in messagenews:e4pTxjXxHHA.736@TK2MSFTNGP06.phx.gbl.. .
> > >I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

>
> > > Command line error BC2014: the value 'None' is invalid for option 'debug'.

>
> > > If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to
> > > PDB-Only
> > > the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on
> > > a
> > > asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
> > > on
> > > release mode compile if it is set to pdb-only.

>
> > > Thanks for your help.- Hide quoted text -

>
> > - Show quoted text -

>
> hai,
> he try build in release mode better set
> <compilation debug="false" />
>
> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted text -
>
> - Show quoted text -


well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /> because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd



news.microsoft.com 07-13-2007 08:53 PM

Re: release mode Compile error BC2014
 
I already have in my web config file <compilation defaultLanguage="vb"
debug="true"/>
and I am getting this message if the debug is set to true or false in the
web.config file.



"Juan T. Llibre" <nomailreplies@nowhere.com> wrote in message
news:%2398ZZbYxHHA.3588@TK2MSFTNGP06.phx.gbl...
> re:
> !> well so what is basically main problem, say i'm not prefer set
> !> <compilation debug="true" /> because of loss some performance
>
> True enough, but to resolve the *current* problem ( that the app won't
> run ),
> the solution is get get the app working *first* and then *later* we worry
> about performance.
>
>
>
> Juan T. Llibre, asp.net MVP
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en español : http://asp.net.do/foros/
> ======================================
> "nahid" <nahidupa@gmail.com> wrote in message
> news:1184354298.750859.148760@q75g2000hsh.googlegr oups.com...
> On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
> wrote:
>> re:
>> !> he try build in release mode better set
>> !> <compilation debug="false" />
>>
>> No. He said that when :
>>
>> !> I change the build configuration to release
>>
>> ...the error occurs, therefore setting it to debug="true" should fix it.
>>
>> Your suggestion, debug="false", is the same as setting the application
>> to release mode, so he would likely continue to get the same error as
>> whenhe manually sets it to "release" mode.
>>
>> Juan T. Llibre, asp.net MVP
>> asp.net faq :http://asp.net.do/faq/
>> foros de asp.net, en español :http://asp.net.do/foros/
>> ======================================"nahid" <nahid...@gmail.com> wrote
>> in messagenews:1184351227.978857.283030@k79g2000hse.g ooglegroups.com...
>>
>> On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
>> wrote:
>>
>>
>>
>>
>>
>> > Just add this entry to the web.config file :

>>
>> > <compilation debug="true" />

>>
>> > Juan T. Llibre, asp.net MVP
>> > asp.net faq :http://asp.net.do/faq/
>> > foros de asp.net, en español :http://asp.net.do/foros/
>> > ======================================

>>
>> > "news.microsoft.com" <twsilentde...@hotmail.com> wrote in
>> > messagenews:e4pTxjXxHHA.736@TK2MSFTNGP06.phx.gbl.. .
>> > >I have an asp.net 2.0 project that when I change the build
>> > >configuration to release I get the following error:

>>
>> > > Command line error BC2014: the value 'None' is invalid for option
>> > > 'debug'.

>>
>> > > If I go into the projects Advanced Compile Options and change the
>> > > Generate Debug Info dropdown from None to PDB-Only
>> > > the error goes away. Can anyone explain why I have to do this and
>> > > what can I do to get the one option to work on a
>> > > asp.net project? It is causing problems because the common project
>> > > is shared with a VB project that gets an error
>> > > on
>> > > release mode compile if it is set to pdb-only.

>>
>> > > Thanks for your help.- Hide quoted text -

>>
>> > - Show quoted text -

>>
>> hai,
>> he try build in release mode better set
>> <compilation debug="false" />
>>
>> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted
>> text -
>>
>> - Show quoted text -

>
> well so what is basically main problem, say i'm not prefer set
> <compilation debug="true" /> because of loss some performance
>
> nahid
> http://nahidulkibria.blogspot.com/
> http://www.kaz.com.bd
>
>




news.microsoft.com 07-13-2007 09:10 PM

Re: release mode Compile error BC2014
 
I already have in my web config file <compilation defaultLanguage="vb"
debug="true"/>
and I am getting this message if the debug is set to true or false in the
web.config file if I am trying to compile in release mode with the Generate
Debug Info dropdown set to None. If I change the Generate Debug Info
dropdown set to PDB-Only or Full then the project compiles fine reguardless
of release or debug mode. I hope this clarifies the problem I am having.


"news.microsoft.com" <twsilentdeath@hotmail.com> wrote in message
news:OdSO1$YxHHA.484@TK2MSFTNGP06.phx.gbl...
>I already have in my web config file <compilation defaultLanguage="vb"
>debug="true"/>
> and I am getting this message if the debug is set to true or false in the
> web.config file.
>
>
>
> "Juan T. Llibre" <nomailreplies@nowhere.com> wrote in message
> news:%2398ZZbYxHHA.3588@TK2MSFTNGP06.phx.gbl...
>> re:
>> !> well so what is basically main problem, say i'm not prefer set
>> !> <compilation debug="true" /> because of loss some performance
>>
>> True enough, but to resolve the *current* problem ( that the app won't
>> run ),
>> the solution is get get the app working *first* and then *later* we worry
>> about performance.
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en español : http://asp.net.do/foros/
>> ======================================
>> "nahid" <nahidupa@gmail.com> wrote in message
>> news:1184354298.750859.148760@q75g2000hsh.googlegr oups.com...
>> On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
>> wrote:
>>> re:
>>> !> he try build in release mode better set
>>> !> <compilation debug="false" />
>>>
>>> No. He said that when :
>>>
>>> !> I change the build configuration to release
>>>
>>> ...the error occurs, therefore setting it to debug="true" should fix it.
>>>
>>> Your suggestion, debug="false", is the same as setting the application
>>> to release mode, so he would likely continue to get the same error as
>>> whenhe manually sets it to "release" mode.
>>>
>>> Juan T. Llibre, asp.net MVP
>>> asp.net faq :http://asp.net.do/faq/
>>> foros de asp.net, en español :http://asp.net.do/foros/
>>> ======================================"nahid" <nahid...@gmail.com> wrote
>>> in messagenews:1184351227.978857.283030@k79g2000hse.g ooglegroups.com...
>>>
>>> On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
>>> wrote:
>>>
>>>
>>>
>>>
>>>
>>> > Just add this entry to the web.config file :
>>>
>>> > <compilation debug="true" />
>>>
>>> > Juan T. Llibre, asp.net MVP
>>> > asp.net faq :http://asp.net.do/faq/
>>> > foros de asp.net, en español :http://asp.net.do/foros/
>>> > ======================================
>>>
>>> > "news.microsoft.com" <twsilentde...@hotmail.com> wrote in
>>> > messagenews:e4pTxjXxHHA.736@TK2MSFTNGP06.phx.gbl.. .
>>> > >I have an asp.net 2.0 project that when I change the build
>>> > >configuration to release I get the following error:
>>>
>>> > > Command line error BC2014: the value 'None' is invalid for option
>>> > > 'debug'.
>>>
>>> > > If I go into the projects Advanced Compile Options and change the
>>> > > Generate Debug Info dropdown from None to PDB-Only
>>> > > the error goes away. Can anyone explain why I have to do this and
>>> > > what can I do to get the one option to work on a
>>> > > asp.net project? It is causing problems because the common project
>>> > > is shared with a VB project that gets an error
>>> > > on
>>> > > release mode compile if it is set to pdb-only.
>>>
>>> > > Thanks for your help.- Hide quoted text -
>>>
>>> > - Show quoted text -
>>>
>>> hai,
>>> he try build in release mode better set
>>> <compilation debug="false" />
>>>
>>> nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide
>>> quoted text -
>>>
>>> - Show quoted text -

>>
>> well so what is basically main problem, say i'm not prefer set
>> <compilation debug="true" /> because of loss some performance
>>
>> nahid
>> http://nahidulkibria.blogspot.com/
>> http://www.kaz.com.bd
>>
>>

>
>





All times are GMT. The time now is 05:38 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.