Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Cisco (http://www.velocityreviews.com/forums/f27-cisco.html)
-   -   PIX 501 PDM (http://www.velocityreviews.com/forums/t42334-pix-501-pdm.html)

tiagoqlopes@gmail.com 01-03-2006 12:17 AM

PIX 501 PDM
 
Hi,

I am new to Cisco PIX firewalls and I am trying to use the PDM to
configure the PIX 501.

I log to the PIX via a browser (have tried multiple IE, Firefox, Opera)
https://192.168.1.1/startup.html I log on the PIX and the browser says
it is loading the java app but I get a java error:

exeception: java.security.AccessControlException: access denied
(java.net.SocketPermission 192.168.1.1:443 connect,resolve)

Any suggestions?

Also, I am intending on using the PIX to enable me to use the Cisco VPN
Client to connect to my workplace from home. Could anyone send me a
sample config for the PIX?

Thank you very much for your help in advance!!


Walter Roberson 01-03-2006 01:08 AM

Re: PIX 501 PDM
 
In article <1136247422.261729.119020@z14g2000cwz.googlegroups .com>,
tiagoqlopes@gmail.com <tiagoqlopes@gmail.com> wrote:
>I am new to Cisco PIX firewalls and I am trying to use the PDM to
>configure the PIX 501.


>I log to the PIX via a browser (have tried multiple IE, Firefox, Opera)
>https://192.168.1.1/startup.html I log on the PIX and the browser says
>it is loading the java app but I get a java error:


>exeception: java.security.AccessControlException: access denied
>(java.net.SocketPermission 192.168.1.1:443 connect,resolve)


>Any suggestions?


http://www.experts-exchange.com/Secu..._21618853.html

summary: you are encountering a problem with your Java.
A couple of possible solutions are given there.

Another site hints that upgrading to pdm 3.0.3 will help.

Kirk Goins 01-03-2006 02:22 AM

Re: PIX 501 PDM
 
Been There, Done That...

Your PC's Java JDK is too high for the version of PDM installed on the
PIX. You need to upgrade the PIX to the latest version of PDM from Cisco.

tiagoqlopes@gmail.com wrote:
> Hi,
>
> I am new to Cisco PIX firewalls and I am trying to use the PDM to
> configure the PIX 501.
>
> I log to the PIX via a browser (have tried multiple IE, Firefox, Opera)
> https://192.168.1.1/startup.html I log on the PIX and the browser says
> it is loading the java app but I get a java error:
>
> exeception: java.security.AccessControlException: access denied
> (java.net.SocketPermission 192.168.1.1:443 connect,resolve)
>
> Any suggestions?
>
> Also, I am intending on using the PIX to enable me to use the Cisco VPN
> Client to connect to my workplace from home. Could anyone send me a
> sample config for the PIX?
>
> Thank you very much for your help in advance!!
>


tiagoqlopes@gmail.com 01-03-2006 11:19 AM

Re: PIX 501 PDM
 
Walter,

Thank you for your hints regarding PDM and Java. Unfortunately I still
have not been able to log into the PDM.

Did a bit more research and have found that this problem is sorted out
with the new PDM update, i.e. 3.0.3.

I have also spoken to Cisco Tech Support and I will have to purchase
the update. This really isn't very good is it?!

Does anyone have the latest version of PDM that could share it with me?


MyndPhlyp 01-03-2006 06:16 PM

Re: PIX 501 PDM
 

<tiagoqlopes@gmail.com> wrote in message
news:1136247422.261729.119020@z14g2000cwz.googlegr oups.com...
> Hi,
>
> I am new to Cisco PIX firewalls and I am trying to use the PDM to
> configure the PIX 501.
>
> I log to the PIX via a browser (have tried multiple IE, Firefox, Opera)
> https://192.168.1.1/startup.html I log on the PIX and the browser says
> it is loading the java app but I get a java error:
>
> exeception: java.security.AccessControlException: access denied
> (java.net.SocketPermission 192.168.1.1:443 connect,resolve)
>
> Any suggestions?


PDM v3.0 and the newer Java runtimes are not compatible. The release notes
for PDM v3.0 indicate only up to Java v1.4.2_03 is supported. The workaround
is to DOWNGRADE the Java runtime.

UNINSTALL the newer Java runtime before installing the downgrade.

Here's a couple of links to help you out.

http://www.cisco.com/univercd/cc/td/...s/pdmrn302.htm

http://java.sun.com/products/archive..._03/index.html



Julian Dragut 01-04-2006 04:07 AM

Re: PIX 501 PDM
 
CONFIRM!!!!!

Been there, done that.....still there actually!

JD

"MyndPhlyp" <nobody@homeright.now> wrote in message
news:Tbzuf.4166$M%4.686@newsread3.news.atl.earthli nk.net...
>
> <tiagoqlopes@gmail.com> wrote in message
> news:1136247422.261729.119020@z14g2000cwz.googlegr oups.com...
>> Hi,
>>
>> I am new to Cisco PIX firewalls and I am trying to use the PDM to
>> configure the PIX 501.
>>
>> I log to the PIX via a browser (have tried multiple IE, Firefox, Opera)
>> https://192.168.1.1/startup.html I log on the PIX and the browser says
>> it is loading the java app but I get a java error:
>>
>> exeception: java.security.AccessControlException: access denied
>> (java.net.SocketPermission 192.168.1.1:443 connect,resolve)
>>
>> Any suggestions?

>
> PDM v3.0 and the newer Java runtimes are not compatible. The release notes
> for PDM v3.0 indicate only up to Java v1.4.2_03 is supported. The
> workaround
> is to DOWNGRADE the Java runtime.
>
> UNINSTALL the newer Java runtime before installing the downgrade.
>
> Here's a couple of links to help you out.
>
> http://www.cisco.com/univercd/cc/td/...s/pdmrn302.htm
>
> http://java.sun.com/products/archive..._03/index.html
>
>




MyndPhlyp 01-04-2006 06:50 AM

Re: PIX 501 PDM
 

"Julian Dragut" <julian.dragut@itsm.ca> wrote in message
news:VkIuf.59145$DQ4.1694032@weber.videotron.net.. .
> CONFIRM!!!!!
>
> Been there, done that.....still there actually!
>
> JD


As for me, I got rid of the Sun Java JRE on one Win2K system entirely and
went back to M$'s crippled version just to support PDM. If I need a newer
version of the JRE I just use my other machines. But the information I
provided was provided to me by Cisco some time back with respect to PDM
3.0(4). I don't recall if I bothered to try JRE 1.4.2.



only1cnoli 04-02-2009 04:16 PM

Re: PIX 501 PDM
 
I have found that JRE 6 update 11 will allow the PDM to function correctly and update 12 or 13 breaks the PDM.

The error message returned from the PDM launcher with update 12 is "Exception: Java.Lang.ArrayIndexOutOfBoundsException: No such child: 0."

This is using a pix 501 with PDM version 3.0(4) and PIX version 6.3(5)


All times are GMT. The time now is 08:29 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.