Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   Session variable values are lost when navigate from one page to an (http://www.velocityreviews.com/forums/t387333-session-variable-values-are-lost-when-navigate-from-one-page-to-an.html)

=?Utf-8?B?U00=?= 02-27-2007 11:26 PM

Session variable values are lost when navigate from one page to an
 
Background
We migrated our Asp.net 1.1 application to Asp.net 2.0 ( just migration )
.. It was working fine in local developer machine and one of our development
testing server.
When we moved to staging server which is also running on windows 2000 server
and we started facing a peculiar issue.
We are able to login successfully every time , however , a click on a link
to move to a a different page on a hyper link.

<asp:HyperLink id="lnkClick" runat="server" ForeColor="Snow"
Font-Italic="True" Font-Size="Small"
Font-Underline="True" Font-Names="Arial" Target="_self"
Font-Bold="True">here</asp:HyperLink>


Code behind has the following code
lnkClick.NavigateUrl = Convert.ToString("Files12/Z_All_allReports.aspx")


What is the issue ?
When the new page is launched , it ends in null reference exception as the
session variables loaded in the previous page were lost.

Our session state is still inproc .
Is it due to any settings on the web server.


Any information is highly appreciated .




All times are GMT. The time now is 07:38 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.