Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Cisco (http://www.velocityreviews.com/forums/f27-cisco.html)
-   -   NAT for backup... (http://www.velocityreviews.com/forums/t373752-nat-for-backup.html)

gkontos 09-29-2006 05:31 PM

NAT for backup...
 
Hi everybody,

Iím experiencing a NAT problem here with my dynamic DSL. Here is the issue. Iíve configured a Cisco 836 router in front of a pix to use the ISDN backup interface when the DSL is down. So far so good the backup interface works fine. But I canít seem to find any solution for NAT to the ISDN interface. Here is the config of the router:

Code:

version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco
!
no logging buffered
enable secret ********************
!
username admin password ************
no aaa new-model
ip subnet-zero
no ip source-route
no ip domain lookup
!
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
isdn switch-type basic-net3
isdn voice-call-failure 0
!
!
!
!
!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
 no cdp enable
!
interface Virtual-Template1
 no ip address
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
 no cdp enable
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 2
 !
 dsl operating-mode auto
 hold-queue 224 in
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
!
interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 shutdown
 dialer pool 1
 dialer idle-timeout 30
 dialer string 8962545555
 dialer watch-group 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname username
 ppp chap password **************
 ppp pap sent-username usename password ******************
!
interface Dialer2
 ip address negotiated
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 2
 dialer-group 2
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname user@isp.tld
 ppp chap password ******************
 ppp pap sent-username user@isp.tld  password **************
!
ip nat inside source static 192.168.0.2 interface Dialer2
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 Dialer1 80
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
line con 0
 exec-timeout 120 0
 no modem enable
 stopbits 1
line aux 0
line vty 0 4
 access-class 1 in
 exec-timeout 120 0
 login local
 length 0
!
scheduler max-task-time 5000
no rcapi server
!
!
!
end

I need the : ip nat inside source static 192.168.0.2 interface Dialer2
Because this is the outside interface of my PIX which accepts some services. However, I canít seem to find a way to NAT to interface Dialer1. (the backup)
Any ideas will be much appreciated.

George


All times are GMT. The time now is 01:16 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.