Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Python (http://www.velocityreviews.com/forums/f43-python.html)
-   -   Pythons Mcmillan Installer : cannot load shared lib (http://www.velocityreviews.com/forums/t328580-pythons-mcmillan-installer-cannot-load-shared-lib.html)

Ajay Bakhshi 02-20-2004 05:12 PM

Pythons Mcmillan Installer : cannot load shared lib
 
Hi,

I have Python-2.2.3/
Mcmillian Installer: _5b5_5
System: HP 11.11 64 bit.

Installer + Python were build with 64 bit support (Compiler flag: +DD64)

I have a Python file Recover.py that calls "C" functions written in an
extension module. Now these "C" functions (in the shared library) load
another shared library using dlopen.

When I run python Recover.py this works just fine.
When the same shared library is opened from a "C" executable, that also
works fine.
BUT when I convert Recover.py into an executable (Using Mcmillian Installer:
http://www.mcmillan-inc.com/ <http://www.mcmillan-inc.com/> - The web site
not working anymore) dlopen gives error.

And dlopen gives the following error:
----------------------------------------------------------------------------
-------------------
Failed to open the library. Err: './nwsnapmgr//libcl.2' contains a static
TLS refere
nce to '__thread_specific_seg' defined in a dynamically loaded library
'./nwsnapmgr//libcl.
2'. Use +tls=dynamic to re-compile './nwsnapmgr//libcl.2'.
Failed to Load DLL /usr/lib/libssdummy.sl or Procedure does not exist
----------------------------------------------------------------------------
-------------------


thanks for any help
-Ajay B



Irit 12-02-2004 07:53 AM

Re: Pythons Mcmillan Installer : cannot load shared lib
 
Hi
I have the same problem
Have you found out what is the reason for this error message,
and how it can be solved ?



All times are GMT. The time now is 03:37 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.