Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Python (http://www.velocityreviews.com/forums/f43-python.html)
-   -   PythonCard newbie question (http://www.velocityreviews.com/forums/t319616-pythoncard-newbie-question.html)

Karl Lopes 07-13-2003 08:37 AM

PythonCard newbie question
 
Hello All,
I downloaded and installed PythonCard. When I try to run the minimal app
in samples
I get the following errors: module' object has no attribute 'Background'.
: module' object has no attribute '__version__'
Any ideas what I am missing here.
Thanks
Karl.

Kevin Altis 07-13-2003 04:59 PM

Re: PythonCard newbie question
 
Yep, the problem is PythonCard has been using the __version__ attribute from
a low-level wxPython module when it shouldn't have and in wxPython 2.4.1 the
location of the __version__ attribute in that low-level module changed and
so it broke PythonCard. This is fixed in cvs and will be fixed in release
0.7.1 which I plan to get out this week after I have recovered from OSCON.

The fix is simple, simply change the line in PythonCardPrototype/model.py to

assert wx.__version__ >= "2.3.3"

the reference in the resourceEditor can be removed entirely.

ka

"Karl Lopes" <karl_lopes@hotmail.com> wrote in message
news:Xns93B71174A7F15karllopeshotmailcom@24.69.255 .211...
> Hello All,
> I downloaded and installed PythonCard. When I try to run the minimal app
> in samples
> I get the following errors: module' object has no attribute 'Background'.
> : module' object has no attribute '__version__'
> Any ideas what I am missing here.
> Thanks
> Karl.




All times are GMT. The time now is 04:09 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.