Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   XML (http://www.velocityreviews.com/forums/f32-xml.html)
-   -   Empty Elements: implicit xsi:nil="true" possible ? (http://www.velocityreviews.com/forums/t168978-empty-elements-implicit-xsi-nil-true-possible.html)

Stefan Prange 03-16-2005 10:29 AM

Empty Elements: implicit xsi:nil="true" possible ?
 
Hi everyone,

I have a little problem here and wasn't able to find a proper solution
by searching the web. So this newsgroups is my last resort ;-)


I have an xml-schema definition of an element which reads:
<xsd:element name="DoubleValue" type="xsd:double" nillable="true"/>

In my instance document I have the following element:
<DoubleValue/>
This line is rejected during schema-validating the document with the
message "The value '' of element 'DoubleValue' is not valid."

When I provide the element explicitely with the "xsi:nil"-attribute it's
parsed as valid. This is the valid element:
<DoubleValue xsi:nil="true"/>

(To make this work I had to extend the root element of my schema
definition with the xsi:nil-attribute. It now looks like this:
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:nil="true">
)


Now, my question is:
Is it possible to tell the XML engine to implicity assume the
xsi:nil="true" attribute when it comes across an empty element?
This would let me keep the simpler form of empty elements (<DoubleValue/>).

I'm using Xerces 2.6.2 as XML engine.

Any help is greatly appreciated.
Thanks in advance.

Stefan



All times are GMT. The time now is 03:49 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.