Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   copyright symbol in web.config (http://www.velocityreviews.com/forums/t121106-copyright-symbol-in-web-config.html)

=?Utf-8?B?bW9XaGl0ZQ==?= 03-07-2006 10:25 PM

copyright symbol in web.config
 
How can I add a copyright symbol to a web.config file? I cannot use the © or
char(169) statements, I need to pass the string onto another application.

The following works on Window XP Professional, IIS 5.1, but fails on Windows
Server 2003, IIS 6.0:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="CopyrightGDT"
value="© 2006 Tele Atlas, Rel. 07/2005."></add>


I suspect the utf-8 encoding is causing the problem, but have not been able
to change to utf-16 or us-ascii with any success.

Thanks, Richard


Scott M. 03-07-2006 10:33 PM

Re: copyright symbol in web.config
 
How about: &copy;



"moWhite" <moWhite@discussions.microsoft.com> wrote in message
news:018BE90A-65BE-482F-8A4C-0D88541627DD@microsoft.com...
> How can I add a copyright symbol to a web.config file? I cannot use the
> or
> char(169) statements, I need to pass the string onto another application.
>
> The following works on Window XP Professional, IIS 5.1, but fails on
> Windows
> Server 2003, IIS 6.0:
>
> <?xml version="1.0" encoding="utf-8" ?>
> <configuration>
> <appSettings>
> <add key="CopyrightGDT"
> value=" 2006 Tele Atlas, Rel. 07/2005."></add>
> .
>
> I suspect the utf-8 encoding is causing the problem, but have not been
> able
> to change to utf-16 or us-ascii with any success.
>
> Thanks, Richard
>




=?Utf-8?B?bW9XaGl0ZQ==?= 03-07-2006 10:46 PM

Re: copyright symbol in web.config
 
Nope. I should have included © in my list with © and char(169). (c) doesn't
work for my marketing folk either.

Any "extended" character would probably suffer the same problem; not just
the copyright symbol.

Richard

"Scott M." wrote:

> How about: ©
>
>
>
> "moWhite" <moWhite@discussions.microsoft.com> wrote in message
> news:018BE90A-65BE-482F-8A4C-0D88541627DD@microsoft.com...
> > How can I add a copyright symbol to a web.config file? I cannot use the ©
> > or
> > char(169) statements, I need to pass the string onto another application.
> >
> > The following works on Window XP Professional, IIS 5.1, but fails on
> > Windows
> > Server 2003, IIS 6.0:
> >
> > <?xml version="1.0" encoding="utf-8" ?>
> > <configuration>
> > <appSettings>
> > <add key="CopyrightGDT"
> > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
> > .
> >
> > I suspect the utf-8 encoding is causing the problem, but have not been
> > able
> > to change to utf-16 or us-ascii with any success.
> >
> > Thanks, Richard
> >

>
>
>


Stephen Ahn 03-08-2006 03:47 AM

Re: copyright symbol in web.config
 
How about

value="&#xA9; 2006 Tele Atlas, Rel. 07/2005."

OR

value="© 2006 Tele Atlas, Rel. 07/2005."

HTH,
Stephen


"moWhite" <moWhite@discussions.microsoft.com> wrote in message
news:018BE90A-65BE-482F-8A4C-0D88541627DD@microsoft.com...
> How can I add a copyright symbol to a web.config file? I cannot use the
> or
> char(169) statements, I need to pass the string onto another application.
>
> The following works on Window XP Professional, IIS 5.1, but fails on
> Windows
> Server 2003, IIS 6.0:
>
> <?xml version="1.0" encoding="utf-8" ?>
> <configuration>
> <appSettings>
> <add key="CopyrightGDT"
> value=" 2006 Tele Atlas, Rel. 07/2005."></add>
> .
>
> I suspect the utf-8 encoding is causing the problem, but have not been
> able
> to change to utf-16 or us-ascii with any success.
>
> Thanks, Richard
>




Joerg Jooss 03-08-2006 06:59 AM

Re: copyright symbol in web.config
 
Thus wrote moWhite,

> How can I add a copyright symbol to a web.config file? I cannot use
> the or char(169) statements, I need to pass the string onto another
> application.
>
> The following works on Window XP Professional, IIS 5.1, but fails on
> Windows Server 2003, IIS 6.0:
>
> <?xml version="1.0" encoding="utf-8" ?>
> <configuration>
> <appSettings>
> <add key="CopyrightGDT"
> value=" 2006 Tele Atlas, Rel. 07/2005."></add>
>
> I suspect the utf-8 encoding is causing the problem, but have not been
> able to change to utf-16 or us-ascii with any success.


is a Unicode character, so UTF-8 cannot be the problem. Do you really save
the web.config as UTF-8?

Cheers,
--
Joerg Jooss
news-reply@joergjooss.de



=?Utf-8?B?bW9XaGl0ZQ==?= 03-08-2006 01:50 PM

Re: copyright symbol in web.config
 
Thanks for the response. I tried © © and get the same web config error. I'm
assuming that ੩ would give the same result.

Has anyone been able to get any special character in a web.config with
encoding set to utf-8?

Richard

"Stephen Ahn" wrote:

> How about
>
> value="© 2006 Tele Atlas, Rel. 07/2005."
>
> OR
>
> value="© 2006 Tele Atlas, Rel. 07/2005."
>
> HTH,
> Stephen
>
>
> "moWhite" <moWhite@discussions.microsoft.com> wrote in message
> news:018BE90A-65BE-482F-8A4C-0D88541627DD@microsoft.com...
> > How can I add a copyright symbol to a web.config file? I cannot use the ©
> > or
> > char(169) statements, I need to pass the string onto another application.
> >
> > The following works on Window XP Professional, IIS 5.1, but fails on
> > Windows
> > Server 2003, IIS 6.0:
> >
> > <?xml version="1.0" encoding="utf-8" ?>
> > <configuration>
> > <appSettings>
> > <add key="CopyrightGDT"
> > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
> > .
> >
> > I suspect the utf-8 encoding is causing the problem, but have not been
> > able
> > to change to utf-16 or us-ascii with any success.
> >
> > Thanks, Richard
> >

>
>
>


=?Utf-8?B?bW9XaGl0ZQ==?= 03-08-2006 01:55 PM

Re: copyright symbol in web.config
 
I'm not sure what you mean by "save the web.config as UTF-8". I'm setting
the encoding attribute to utf-8 in the xml declaration, but I use either
notepad or VS 2003 IDE to edit and save the actual file. I would assume that
its a dos or windows text file. The copyright symbol © shows up fine in the
actual file.

Richard

"Joerg Jooss" wrote:

> Thus wrote moWhite,
>
> > How can I add a copyright symbol to a web.config file? I cannot use
> > the © or char(169) statements, I need to pass the string onto another
> > application.
> >
> > The following works on Window XP Professional, IIS 5.1, but fails on
> > Windows Server 2003, IIS 6.0:
> >
> > <?xml version="1.0" encoding="utf-8" ?>
> > <configuration>
> > <appSettings>
> > <add key="CopyrightGDT"
> > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
> > …
> > I suspect the utf-8 encoding is causing the problem, but have not been
> > able to change to utf-16 or us-ascii with any success.

>
> © is a Unicode character, so UTF-8 cannot be the problem. Do you really save
> the web.config as UTF-8?
>
> Cheers,
> --
> Joerg Jooss
> news-reply@joergjooss.de
>
>
>


Joerg Jooss 03-08-2006 07:31 PM

Re: copyright symbol in web.config
 
Thus wrote moWhite,

> I'm not sure what you mean by "save the web.config as UTF-8". I'm
> setting the encoding attribute to utf-8 in the xml declaration, but I
> use either notepad or VS 2003 IDE to edit and save the actual file. I
> would assume that its a dos or windows text file. The copyright
> symbol shows up fine in the actual file.


Simply setting an XML declaration with encoding attribute doesn't mean the
file actual uses that encoding. In Notepad, you can select the encoding in
the Save As dialog. In VS2005, you can select the encoding under File->Advanced
Save Options.

Cheers,
--
Joerg Jooss
news-reply@joergjooss.de



=?Utf-8?B?bW9XaGl0ZQ==?= 03-08-2006 08:17 PM

Re: copyright symbol in web.config
 
You are exactly correct. I use a file compare program to compare my web
config files on various servers and keep them in sync. It changes the
encoding to ANSI. I've made the correction and am no longer failing on the
copyright symbol. This has been a problem for months with zero solution.

Thanks, Richard


"Joerg Jooss" wrote:

> Thus wrote moWhite,
>
> > I'm not sure what you mean by "save the web.config as UTF-8". I'm
> > setting the encoding attribute to utf-8 in the xml declaration, but I
> > use either notepad or VS 2003 IDE to edit and save the actual file. I
> > would assume that its a dos or windows text file. The copyright
> > symbol © shows up fine in the actual file.

>
> Simply setting an XML declaration with encoding attribute doesn't mean the
> file actual uses that encoding. In Notepad, you can select the encoding in
> the Save As dialog. In VS2005, you can select the encoding under File->Advanced
> Save Options.
>
> Cheers,
> --
> Joerg Jooss
> news-reply@joergjooss.de
>
>
>


Blue Streak 03-08-2006 08:52 PM

Re: copyright symbol in web.config
 
Would using (c) as opposed to be an option?

....Just a thought.



All times are GMT. The time now is 02:08 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.